Gem

必要なライブラリをインストール(bundle)

適応バージョン

  • 1.0.0
  • 1.1.0
  • 1.1.1
  • 1.1.6
  • 1.2.0
  • 1.2.6
  • 2.0.0
  • 2.0.1
  • 2.0.3
  • 2.1.0
  • 2.2.1
  • 2.3.2
  • 2.3.8
  • 3.0.0
  • 3.0.5
  • 3.0.7
  • 3.0.9
  • 3.1.0
  • 3.2.3
  • 3.2.8
  • 3.2.13
  • 4.0.0
  • 4.1.0
  • 4.2.1

説明

RubyGemsの管理ツール

コマンド一覧

コマンド説明
bundle install依存ライブラリのインストール
bundle update依存ライブラリのアップデート
bundle package依存ライブラリを「vender/cache」以下にまとめる
bundle check依存ライブラリがインストールされているかチェック
bundle listインストールされているライブラリの一覧
bundle showgemファイルのソースのパスを表示
bundle initgemを初期化

依存関係のあるライブラリをインストール
$ bundle install
依存関係のあるライブラリをアップデート
$ bundle update

Gemfile

説明

Railsで使用するGemの依存関係を管理するファイル

使い方

gem ライブラリ名 [, バージョン, オプション]

バージョン

バージョン説明
x.x.xバージョンを固定
>= x.x.xx.x.x以上のバージョンが必要
>= x.x.x, < y.y.yx.x.x以上、y.y.y以下のバージョンが必要
~> x.0x.1からx.9は良いが、メインのバージョンがあがるとは不可
例えば、3.2は良いが、4.0は不可など

オプション

オプション説明
:branch対象となるブランチ
:group or :groups環境(test/development/production)
:gitgitレポジトリ
:requirerequireするgem
:platformsgemを利用するプラットフォーム
:pathgemファイルのディレクトリを指定

Rails3.2.1で固定
gem 'rails7, '3.2.1'
最新のRailsを使用
gem 'rails', :git => 'git://github.com/rails/rails.git'

その他

初めに生成されるファイル例
source 'https://rubygems.org'

gem 'rails', '3.2.1'

gem 'sqlite3'

gem 'json'

group :assets do
  gem 'sass-rails',   '~> 3.2.3'
  gem 'coffee-rails', '~> 3.2.1'

  gem 'uglifier', '>= 1.0.3'
end
source

gemで使用するライブラリが置いてあるURL

参考サイト